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Support

Bosch Contact Information
Bosch Security Systems, Inc.
– Technical Support: 1-800-289-0096

Monday: 9:00 AM to 8:00 PM Eastern Time
Tuesday-Friday: 8:00 AM to 8:00 PM Eastern Time
Email: Technical.Support@us.bosch.com
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Limitations
The following limitations are currently present with the Configurator application.
Does not support adding Alarm Inputs and Relays to the Device configuration for cameras
configured to VRM and stand-alone cameras.
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Prerequisites
The following software packages should be installed on the target machine (PC) before
installing Bosch Integration Configurator.
– Microsoft .NET 4.0
– Bosch Video-SDK 6.02 or greater
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Installation
1. Run the BoschIntegrationConfiguratorSetup.exe file on the target machine.
2. Proceed with clicking on the default buttons to complete the installation.
3. Wait until installation is complete.
4. Click the Close button to finish the installation process.
5. The files will be installed under Program Files (x86)\Bosch\Bosch Integration

Configurator.
6. The application folder “Bosch Integration Configurator” will appear in the All Programs

list.
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Configuration

Start Bosch Integration Configurator
Start the Bosch Integration Configurator application from:
– the installation folder OR
– the Windows Start menu

From here you can:
– Add a device.
– Delete a recorder.
– Change credentials.
– Change global camera settings.
– Delete a camera.
– Configure Asset IDs.
– Load a configuration file.
– Save a configuration file.

Add Recorders

Add Recorders via Auto Detection
4 From the Actions drop-down menu, click Autodetect devices to auto detect the devices.
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The network devices appear in the “Device Selection” list as shown below.

1. Select the device(s) to be added to the recorder list by clicking on the device(s). Note:
For multiple device selection, press the Ctrl key on the keyboard while selecting the
device.

2. Click the button Add Selected to initiate adding of the device/s to the recorder list.
3. Enter the device credentials for each of the selected devices.
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Note: In case the device credentials are the same for selected devices, the user can enable the
option Use credentials above as default to hide the Device Credentials for each of the
devices.

Note: For DIVAR IP / VRM / DLA recorders, the Device Credentials will appear automatically for
each camera managed by the DIVAR IP / VRM / DLA. The user has the option to include or
exclude the configured devices on the DIVAR IP / VRM / DLA.
Clicking the Cancel button for the recorder will exclude the recorder from the recorder list.
Clicking the Cancel button for a device managed by DIVAR IP / VRM / DLA recorders will
exclude the device under the respective recorder.
4 Note that the selected devices appears in the device tree as shown below.
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Adding a Local Recorder Manually
4 From the Actions drop-down menu, click Add device.

The Add Device fields appear.

5.2.2
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1. Enter the IP Address.
2. Select the respective Device Type from the list.
3. Select the appropriate option in Device Location:
– If the VRM / DIP does not use Port forwarding, select Local (the default option for

recorders).
– If using Port forwarding, select Remote.
Port forwarding is used for restricting camera accessibility externally. In this configuration,
only the IP addresses of the recorders are accessible externally and all cameras configured to
the recorders will have a local IP address such as 192.168.0.xxx and are not directly
accessible. The access to the cameras goes through the DIP’s IP address + the particular port
on it.
1. Click OK.
2. Enter the device credentials for the added device.

Note: For DIVAR IP / VRM / DLA recorders, the Device Credentials will appear automatically for
each camera managed by the DIVAR IP / VRM / DLA. The user has the option to include or
exclude the configured devices on the DIVAR IP / VRM / DLA.
Clicking the Cancel button for the recorder will exclude the recorder from the recorder list.
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Clicking the Cancel button for a device managed by DIVAR IP / VRM / DLA recorders will
exclude the device under the respective recorder.

Adding a Remote Recorder Manually
4 From the Actions drop-down menu, click Add device.

The Add Device fields appear.

4 For remote DIVAR IP devices, fill in the following required fields:

– IP Address: the IP address of the remote DIVAR IP
– Device Type: DIVAR IP
– Device Location: Remote
– URI schema: bvms://
– Port Number: the BVMS port number
1. Click OK to add the remote DIVAR IP to the recorder list automatically.
2. Enter the following device credentials:
– User Name: The BVMS username
– Password: The BVMS password
Note: The Device Credentials do not appear for devices managed by the remote DIVAR IP and
will be added as inputs automatically under the remote DIVAR IP recorder in the device tree.
4 For VRM / DIP, fill in the appropriate fields. For Device Location:

– Select the option Local if VRM / DIP does not use Port forwarding.
– Select the option Remote if the VRM / DIP uses Port forwarding.

5.2.3
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Port forwarding is used for restricting camera accessibility externally. In this configuration,
only the IP addresses of the recorders are accessible externally and all cameras configured to
the recorders will have a local IP address such as 192.168.0.xxx and are not directly
accessible. The access to the cameras goes through the DIP’s IP address + the particular port
on it.

Delete a Recorder
Click on the respective recorder from the recorder list that needs to be deleted in order to
display the Recorder Properties. Click on the Delete Recorder button to delete the recorder
from the configuration.

The user will be prompted by a confirmation dialog to confirm the deletion of the recorder.
Click on “Yes” button to delete the recorder. Click on No button to cancel deletion.

Import Cameras
This feature can be used to import the new cameras added to an existing device configuration.
Click on the respective recorder from the recorder list. Click on the Import button to reimport
the camera configuration to the existing device configuration file.
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Configure Global Camera Settings
Click on the respective recorder from the recorder list. Click on the Global Camera Settings
button to configure the global settings for all the cameras configured to the recorder.

The Global Camera Settings form will be displayed.

Click on the Use Global Camera Settings checkbox will prompt the user with the following
informational message.

5.5
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Clicking on OK button on the above informational message will display the Global Camera
Settings form with the camera settings. The user can now set any of the camera settings.
Please note the same settings will be applied for all cameras configured to the recorder that
have Use Global Camera Settings set in the camera setting.

– Text Overlays – If this option is set, it will display the camera text overlay (Camera name,
time stamp etc.) in live and playback mode

– Keep Aspect Ratio – If this option is set, it will enable aspect ratio correction by
letterboxing. If turned off, the video will fill the complete window area.

– IVA Overlays – If this option is set, it displays the IVA overlay of the moving objects.
– IVA Events – If this option is set, the IVA events will be received and processed.
– Use Global Camera Password – If this option is set, the user has to enter the global

camera password. The global camera password will be set as the password for all
cameras configured to the recorder that have the Use Global Camera Settings” set in the
camera setting.

Clicking on Accept button will prompt the user with a confirmation dialog and clicking on OK
button will apply the global camera settings for all cameras configured to the recorder that
have Use Global Camera Settings enabled in the camera setting.
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Change Recorder Credentials
Click on the recorder to display the Recorder Properties.

Click on Credentials button to display the Device Credentials form. Enter the User Name and
Password to modify the Device credentials.

Modify Camera Properties
Note: This section is only valid for VRM / DLA / DIVAR IP/ BVIP IP on edge recording. Since the
default setting for all cameras is “Fixed,” each PTZ camera configured must be modified as
mentioned below to enable the PTZ functionality.

5.6

5.7

Bosch Integration Configurator Configuration | en 17

Bosch Security Systems User Guide 2016.11 | 1.0 |



Expand the recorder and click on the camera input to display the Camera Properties as
shown.

Click on Modify button will display the camera properties form. The user can change the
camera properties using this form. For PTZ Cameras the PTZ Model should be selected as
Bosch-Auto Dome Bilinx.

Please note that if the Use Global Camera Settings is set, unchecking it and making any
changes to camera settings and applying the changes will make the camera settings local
applicable only to that respective camera.
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Delete Camera
Expand the recorder and click on the camera input to display the Camera Properties as
shown.

Click on Delete Camera button. The user will be prompted by a confirmation dialog to confirm
the deletion of the camera. Click on “Yes” button to delete the camera. Click on No button to
cancel deletion.

Configure Asset IDs
Under the Tools drop-down menu, click on Settings to configure the Asset ID.
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The AssetID Settings form is displayed as shown below.

The Asset ID can be configured in 3 ways as described below:
– Incremental
This setting means that the Asset IDs will begin at 1 and i incrementally until they reach
32767.
Command Line Configuration: >BoschIntegrationConfigurator.exe
– VRM Track ID
When this option is selected, the VRM Track ID will be used as the Asset ID.
Command Line Configuration: >BoschIntegrationConfigurator.exe /T
– Pattern
When this option is selected, the AssetID will be taken from the name of a camera, using the
specified pattern.
Command Line Configuration: >BoschIntegrationConfigurator.exe /P: [%d]
Example: This will execute the tool in pattern mode with the pattern [%d]. A camera that has
the name "Main Entrance [001]" can use the pattern "[%d]" to determine that the AssetID is 1.

Load a Configuration File
Under the File drop-down menu, click on Load to browse and load an existing device
configuration file.

5.10
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After loading the device configuration file the recorders are populated under the Bosch
Recorders device tree. Now the existing configuration can be modified as per user’s choice.

Save a Configuration File
After adding the recorder configuration or making any changes to the loaded device
configuration, the file can be saved.
Under the File drop-down menu, click on Save to browse and save the device configuration
file.

After making any changes to the loaded device configuration, the file can be saved as new
device configuration file.
Under the File drop-down menu, click on Save As to browse and save it as a new device
configuration file.

5.11
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Uninstallation
1. From Windows Start > Control Panel, select the option Uninstall a program under

Programs.

2. Right-click Bosch Integration Configurator.

1. Click Uninstall to start the uninstallation process.
2. Wait until uninstallation is complete and then review the list of applications in Programs

and Features to verify that Configurator has been uninstalled successfully.
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